Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 1 | # |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 2 | # Copyright (C) 2015 The Android Open Source Project |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 3 | # |
| 4 | # Licensed under the Apache License, Version 2.0 (the "License"); |
| 5 | # you may not use this file except in compliance with the License. |
| 6 | # You may obtain a copy of the License at |
| 7 | # |
| 8 | # http://www.apache.org/licenses/LICENSE-2.0 |
| 9 | # |
| 10 | # Unless required by applicable law or agreed to in writing, software |
| 11 | # distributed under the License is distributed on an "AS IS" BASIS, |
| 12 | # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. |
| 13 | # See the License for the specific language governing permissions and |
| 14 | # limitations under the License. |
| 15 | # |
| 16 | |
| 17 | header: |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 18 | summary: Conversion Functions |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 19 | description: |
Brian Carlstrom | f166ab6 | 2016-03-29 14:49:03 -0700 | [diff] [blame] | 20 | The functions below convert from a numerical vector type to another, or from one color |
Jean-Luc Brouillet | 6386ceb | 2015-04-28 15:06:30 -0700 | [diff] [blame] | 21 | representation to another. |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 22 | end: |
| 23 | |
| 24 | function: convert_#3#1 |
| 25 | version: 9 |
| 26 | attrib: const |
| 27 | w: 2, 3, 4 |
| 28 | t: u8, u16, u32, i8, i16, i32, f32 |
| 29 | t: u8, u16, u32, i8, i16, i32, f32 |
| 30 | ret: #3#1 |
| 31 | arg: #2#1 v, compatible(#3) |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 32 | summary: Convert numerical vectors |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 33 | description: |
Jean-Luc Brouillet | 6386ceb | 2015-04-28 15:06:30 -0700 | [diff] [blame] | 34 | Converts a vector from one numerical type to another. The conversion are done entry per entry. |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 35 | |
Jean-Luc Brouillet | 6386ceb | 2015-04-28 15:06:30 -0700 | [diff] [blame] | 36 | E.g calling <code>a = convert_short3(b);</code> is equivalent to doing |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 37 | <code>a.x = (short)b.x; a.y = (short)b.y; a.z = (short)b.z;</code>. |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 38 | |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 39 | Converting floating point values to integer types truncates. |
| 40 | |
| 41 | Converting numbers too large to fit the destination type yields undefined results. |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 42 | For example, converting a float that contains 1.0e18 to a short is undefined. |
| 43 | Use @clamp() to avoid this. |
| 44 | end: |
| 45 | |
| 46 | function: convert_#3#1 |
| 47 | version: 21 |
| 48 | attrib: const |
| 49 | w: 2, 3, 4 |
| 50 | t: u64, i64, f64 |
| 51 | t: u64, i64, f64 |
| 52 | ret: #3#1 |
| 53 | arg: #2#1 v, compatible(#3) |
| 54 | end: |
| 55 | |
| 56 | function: convert_#3#1 |
| 57 | version: 21 |
| 58 | attrib: const |
| 59 | w: 2, 3, 4 |
| 60 | t: u64, i64, f64 |
| 61 | t: u8, u16, u32, i8, i16, i32, f32 |
| 62 | ret: #3#1 |
| 63 | arg: #2#1 v, compatible(#3) |
| 64 | end: |
| 65 | |
| 66 | function: convert_#3#1 |
| 67 | version: 21 |
| 68 | attrib: const |
| 69 | w: 2, 3, 4 |
| 70 | t: u8, u16, u32, i8, i16, i32, f32 |
| 71 | t: u64, i64, f64 |
| 72 | ret: #3#1 |
| 73 | arg: #2#1 v, compatible(#3) |
| 74 | end: |
| 75 | |
Pirama Arumuga Nainar | 193847b | 2015-12-09 15:54:35 -0800 | [diff] [blame] | 76 | function: convert_#3#1 |
Pirama Arumuga Nainar | 132b31f | 2016-02-18 14:46:28 -0800 | [diff] [blame] | 77 | version: 24 |
Pirama Arumuga Nainar | 193847b | 2015-12-09 15:54:35 -0800 | [diff] [blame] | 78 | attrib: const |
| 79 | w: 2, 3, 4 |
| 80 | t: f16 |
Pirama Arumuga Nainar | 7c314df | 2016-03-29 11:15:21 -0700 | [diff] [blame] | 81 | t: u8, u16, u32, u64, i8, i16, i32, i64, f16, f32, f64 |
Pirama Arumuga Nainar | 193847b | 2015-12-09 15:54:35 -0800 | [diff] [blame] | 82 | ret: #3#1 |
| 83 | arg: #2#1 v, compatible(#3) |
Pirama Arumuga Nainar | 193847b | 2015-12-09 15:54:35 -0800 | [diff] [blame] | 84 | end: |
| 85 | |
| 86 | function: convert_#3#1 |
Pirama Arumuga Nainar | 132b31f | 2016-02-18 14:46:28 -0800 | [diff] [blame] | 87 | version: 24 |
Pirama Arumuga Nainar | 193847b | 2015-12-09 15:54:35 -0800 | [diff] [blame] | 88 | attrib: const |
| 89 | w: 2, 3, 4 |
| 90 | t: u8, u16, u32, u64, i8, i16, i32, i64, f32, f64 |
| 91 | t: f16 |
| 92 | ret: #3#1 |
| 93 | arg: #2#1 v, compatible(#3) |
Pirama Arumuga Nainar | 193847b | 2015-12-09 15:54:35 -0800 | [diff] [blame] | 94 | end: |
| 95 | |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 96 | function: rsPackColorTo8888 |
| 97 | attrib: const |
| 98 | ret: uchar4 |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 99 | arg: float r, "Red component." |
| 100 | arg: float g, "Green component." |
| 101 | arg: float b, "Blue component." |
| 102 | summary: Create a uchar4 RGBA from floats |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 103 | description: |
Jean-Luc Brouillet | f1001ad | 2015-05-04 14:24:48 -0700 | [diff] [blame] | 104 | Packs three or four floating point RGBA values into a uchar4. |
| 105 | |
Jean-Luc Brouillet | ffc1710 | 2015-08-13 22:47:06 -0700 | [diff] [blame] | 106 | The input values are typically between 0.0f and 1.0f inclusive. For input values outside |
Jean-Luc Brouillet | f1001ad | 2015-05-04 14:24:48 -0700 | [diff] [blame] | 107 | of this range, the resulting outputs will be clamped to be between 0 and 255. As this |
| 108 | clamping may be done after the input is multiplied by 255.f and converted to an integer, |
Jean-Luc Brouillet | ffc1710 | 2015-08-13 22:47:06 -0700 | [diff] [blame] | 109 | input numbers greater than INT_MAX/255.f or less than INT_MIN/255.f result in |
Jean-Luc Brouillet | f1001ad | 2015-05-04 14:24:48 -0700 | [diff] [blame] | 110 | undefined behavior. |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 111 | |
Jean-Luc Brouillet | 6386ceb | 2015-04-28 15:06:30 -0700 | [diff] [blame] | 112 | If the alpha component is not specified, it is assumed to be 1.0, i.e. the result will |
| 113 | have an alpha set to 255. |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 114 | test: none |
| 115 | end: |
| 116 | |
| 117 | function: rsPackColorTo8888 |
| 118 | attrib: const |
| 119 | ret: uchar4 |
| 120 | arg: float r |
| 121 | arg: float g |
| 122 | arg: float b |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 123 | arg: float a, "Alpha component." |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 124 | test: none |
| 125 | end: |
| 126 | |
| 127 | function: rsPackColorTo8888 |
| 128 | attrib: const |
| 129 | ret: uchar4 |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 130 | arg: float3 color, "Vector of 3 or 4 floats containing the R, G, B, and A values." |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 131 | test: none |
| 132 | end: |
| 133 | |
| 134 | function: rsPackColorTo8888 |
| 135 | attrib: const |
| 136 | ret: uchar4 |
| 137 | arg: float4 color |
| 138 | test: none |
| 139 | end: |
| 140 | |
| 141 | function: rsUnpackColor8888 |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 142 | # NOTE: The = below indicates that the generator should not add "overloadable" by default. |
| 143 | # We're doing this to stay backward compatible with the unusual declaration used when this |
| 144 | # function was introduced. |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 145 | attrib: =const |
| 146 | ret: float4 |
| 147 | arg: uchar4 c |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 148 | summary: Create a float4 RGBA from uchar4 |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 149 | description: |
Jean-Luc Brouillet | 6386ceb | 2015-04-28 15:06:30 -0700 | [diff] [blame] | 150 | Unpacks a uchar4 color to float4. The resulting floats will be between 0.0 and 1.0 inclusive. |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 151 | test: none |
| 152 | end: |
| 153 | |
| 154 | function: rsYuvToRGBA_#2#1 |
| 155 | attrib: const |
| 156 | w: 4 |
| 157 | t: u8, f32 |
| 158 | ret: #2#1 |
Jean-Luc Brouillet | 6386ceb | 2015-04-28 15:06:30 -0700 | [diff] [blame] | 159 | arg: uchar y, "Luminance component." |
| 160 | arg: uchar u, "U chrominance component." |
| 161 | arg: uchar v, "V chrominance component." |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 162 | summary: Convert a YUV value to RGBA |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 163 | description: |
Jean-Luc Brouillet | 20b27d6 | 2015-04-03 14:39:53 -0700 | [diff] [blame] | 164 | Converts a color from a YUV representation to RGBA. |
| 165 | |
| 166 | We currently don't provide a function to do the reverse conversion. |
Jean-Luc Brouillet | be21638 | 2015-03-22 12:44:27 -0700 | [diff] [blame] | 167 | test: none |
| 168 | end: |