blob: 6ae7b401d4dec583e5085587cf448e101db2e7ef [file] [log] [blame]
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -07001#
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -07002# Copyright (C) 2015 The Android Open Source Project
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -07003#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -070018summary: Conversion Functions
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070019description:
Brian Carlstromf166ab62016-03-29 14:49:03 -070020 The functions below convert from a numerical vector type to another, or from one color
Jean-Luc Brouillet6386ceb2015-04-28 15:06:30 -070021 representation to another.
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070022end:
23
24function: convert_#3#1
25version: 9
26attrib: const
27w: 2, 3, 4
28t: u8, u16, u32, i8, i16, i32, f32
29t: u8, u16, u32, i8, i16, i32, f32
30ret: #3#1
31arg: #2#1 v, compatible(#3)
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -070032summary: Convert numerical vectors
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070033description:
Jean-Luc Brouillet6386ceb2015-04-28 15:06:30 -070034 Converts a vector from one numerical type to another. The conversion are done entry per entry.
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070035
Jean-Luc Brouillet6386ceb2015-04-28 15:06:30 -070036 E.g calling <code>a = convert_short3(b);</code> is equivalent to doing
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -070037 <code>a.x = (short)b.x; a.y = (short)b.y; a.z = (short)b.z;</code>.
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070038
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -070039 Converting floating point values to integer types truncates.
40
41 Converting numbers too large to fit the destination type yields undefined results.
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070042 For example, converting a float that contains 1.0e18 to a short is undefined.
43 Use @clamp() to avoid this.
44end:
45
46function: convert_#3#1
47version: 21
48attrib: const
49w: 2, 3, 4
50t: u64, i64, f64
51t: u64, i64, f64
52ret: #3#1
53arg: #2#1 v, compatible(#3)
54end:
55
56function: convert_#3#1
57version: 21
58attrib: const
59w: 2, 3, 4
60t: u64, i64, f64
61t: u8, u16, u32, i8, i16, i32, f32
62ret: #3#1
63arg: #2#1 v, compatible(#3)
64end:
65
66function: convert_#3#1
67version: 21
68attrib: const
69w: 2, 3, 4
70t: u8, u16, u32, i8, i16, i32, f32
71t: u64, i64, f64
72ret: #3#1
73arg: #2#1 v, compatible(#3)
74end:
75
Pirama Arumuga Nainar193847b2015-12-09 15:54:35 -080076function: convert_#3#1
Pirama Arumuga Nainar132b31f2016-02-18 14:46:28 -080077version: 24
Pirama Arumuga Nainar193847b2015-12-09 15:54:35 -080078attrib: const
79w: 2, 3, 4
80t: f16
Pirama Arumuga Nainar7c314df2016-03-29 11:15:21 -070081t: u8, u16, u32, u64, i8, i16, i32, i64, f16, f32, f64
Pirama Arumuga Nainar193847b2015-12-09 15:54:35 -080082ret: #3#1
83arg: #2#1 v, compatible(#3)
Pirama Arumuga Nainar193847b2015-12-09 15:54:35 -080084end:
85
86function: convert_#3#1
Pirama Arumuga Nainar132b31f2016-02-18 14:46:28 -080087version: 24
Pirama Arumuga Nainar193847b2015-12-09 15:54:35 -080088attrib: const
89w: 2, 3, 4
90t: u8, u16, u32, u64, i8, i16, i32, i64, f32, f64
91t: f16
92ret: #3#1
93arg: #2#1 v, compatible(#3)
Pirama Arumuga Nainar193847b2015-12-09 15:54:35 -080094end:
95
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070096function: rsPackColorTo8888
97attrib: const
98ret: uchar4
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -070099arg: float r, "Red component."
100arg: float g, "Green component."
101arg: float b, "Blue component."
102summary: Create a uchar4 RGBA from floats
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -0700103description:
Jean-Luc Brouilletf1001ad2015-05-04 14:24:48 -0700104 Packs three or four floating point RGBA values into a uchar4.
105
Jean-Luc Brouilletffc17102015-08-13 22:47:06 -0700106 The input values are typically between 0.0f and 1.0f inclusive. For input values outside
Jean-Luc Brouilletf1001ad2015-05-04 14:24:48 -0700107 of this range, the resulting outputs will be clamped to be between 0 and 255. As this
108 clamping may be done after the input is multiplied by 255.f and converted to an integer,
Jean-Luc Brouilletffc17102015-08-13 22:47:06 -0700109 input numbers greater than INT_MAX/255.f or less than INT_MIN/255.f result in
Jean-Luc Brouilletf1001ad2015-05-04 14:24:48 -0700110 undefined behavior.
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -0700111
Jean-Luc Brouillet6386ceb2015-04-28 15:06:30 -0700112 If the alpha component is not specified, it is assumed to be 1.0, i.e. the result will
113 have an alpha set to 255.
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -0700114test: none
115end:
116
117function: rsPackColorTo8888
118attrib: const
119ret: uchar4
120arg: float r
121arg: float g
122arg: float b
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -0700123arg: float a, "Alpha component."
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -0700124test: none
125end:
126
127function: rsPackColorTo8888
128attrib: const
129ret: uchar4
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -0700130arg: float3 color, "Vector of 3 or 4 floats containing the R, G, B, and A values."
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -0700131test: none
132end:
133
134function: rsPackColorTo8888
135attrib: const
136ret: uchar4
137arg: float4 color
138test: none
139end:
140
141function: rsUnpackColor8888
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -0700142# NOTE: The = below indicates that the generator should not add "overloadable" by default.
143# We're doing this to stay backward compatible with the unusual declaration used when this
144# function was introduced.
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -0700145attrib: =const
146ret: float4
147arg: uchar4 c
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -0700148summary: Create a float4 RGBA from uchar4
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -0700149description:
Jean-Luc Brouillet6386ceb2015-04-28 15:06:30 -0700150 Unpacks a uchar4 color to float4. The resulting floats will be between 0.0 and 1.0 inclusive.
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -0700151test: none
152end:
153
154function: rsYuvToRGBA_#2#1
155attrib: const
156w: 4
157t: u8, f32
158ret: #2#1
Jean-Luc Brouillet6386ceb2015-04-28 15:06:30 -0700159arg: uchar y, "Luminance component."
160arg: uchar u, "U chrominance component."
161arg: uchar v, "V chrominance component."
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -0700162summary: Convert a YUV value to RGBA
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -0700163description:
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -0700164 Converts a color from a YUV representation to RGBA.
165
166 We currently don't provide a function to do the reverse conversion.
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -0700167test: none
168end: